Stop the dialler!

How can I stop numbers entered as text being automatically converted to a phone number and the dialler screen opening up? I want to keep those numbers as text, I don’t want to ring them up! Help?

Settings>Message View>Highlight phone numbers?