Return key keeps leaving

See image, please help? Thanks!

Hello, under General Settings, just set the “Smiley key” option to “off” instead of “auto”, or turn off “Custom smileys” completely

That worked. I guess I was confused by the fact that Custom smileys was not checked at all, which implies to me that the feature is completely disabled. I had to enable it to turn off Smiley key. Thanks for your direction.