Autotext with T9 mode

Could we get autotext to work whilst using T9 mode? Autotext only seems to work when I turn off T9 and manually type out the words for it to appear in the suggestion bar (eg. bomb -> :bomb:).